Failed to activate required window

Share your macros, knowledge, solutions, services, ...
Post Reply
Posts: 1
Joined: Fri Aug 04, 2017 12:20 am

Failed to activate required window

Post by dawrightau » Fri Aug 04, 2017 1:04 am


I am posting this again as when I pressed submit the message was submitted but the new topic didn't display.

I am using MacroToolbar v7.6.9. Free

I am trying to write a macro to switch to Microsoft Edge, copy the active page url, switch to Firefox, open a new tab, paste and goto the pasted url.

Whenever I run a macro to activate a window, the window activates (good), but the execution then stalls until I get the "Failed to activate required window" message (See attached error message). It does this regardless of whether the program being activated is a browser or office program (ie word, excel etc). The execution of the macro stalls until it times out.

1. The error attachment is for the following code


2. The other unexpected behavior I get is when I run the macro, I get the stop/pause dialog with partial progress green bar. Clicking on the stop or pause either does nothing (ie control is lost until the macro eventually times out) or it hides but control of the screen is still lost until the macro times out. This can be up to a minute of lost control. Pressing Shift+Escape also does nothing. (See other attachment)

3. I cannot find any help on this error.

4. If I call another macro , i.e. a macro as follows with the command <exitmacro>, I dont get the error message just a message saying macro execution stopped.

<actwin>("Edge",0,0,"Exit Macro")

5. The following script is what I am actually trying to achieve which falls over on line 3

<msg>(100,100,"'Edge' is not opened!","Message",1)
<msg>(100,100,"'Firefox' is not opened!","Message",1)

Any assistance would be appreciated.

Thank you

MacroToolBar-Stop-Pause.png (2.73 KiB) Viewed 6155 times
MacroToolBar-Error.png (6.89 KiB) Viewed 6155 times

Post Reply